Unity-初心者ユニティの使い方メモ【UTMEMO】ブログ版

新しくライターさんが参加しました。Unityの使い方。アプリ、ゲームを作る時の開発作業ログ等。もしや、誰かのお役に立てたなら幸いです。

Google Play の対象 API レベルの要件を満たす

突然現れたエラー

 

現在、お客様のアプリは API レベル 28 を対象にしています。セキュリティとパフォーマンスが最適化された最新の API を利用するには、API レベル 29 以上を対象にする必要があります。アプリの対象 API レベルを 29 以上に変更してください。

 

注: 2020 年 11 月 2 日以降、アプリのアップデートは Android 10(API レベル 29)以上を対象にする必要があります。 

 

 とのこと。

 

unityエディターをAPIレベル29にフィットさせる 

・ Android Studio起動

・ SDK Manager画面ひらく

・ 対象APIをチェックしてインストール

・ Preferences→External ToolsのSDKのパスを設定(Android Studioを参考)

blog.lab7.biz

 

 

■ たまにTrget API Level 29が表示されない

[ 対処法A ]/こっちのほうがいい??

・ エディタが2020版だとうまくうごくので、そのエディタのSDKパスを設定して開きなおす→いまのところ動いている???

 

[ 対処法B ]

・ うまくリロードできていないような感じがする

→ 他のうまくリロードできているプロジェクトを同時に開くといいかもしれない

その際、アンドロイドスタジオとsdk manegerを開きパスを選択状態にしておく?? 

 ※ パスをペーストしなおすか、Android StudioSDK managerでチェック入れなおす必要がある???

インストールしなおす・・・???

 (SDKひらく→edit開いたまま→unityプロジェクト開く??)

 

 

■ invalid android sdk directory

Unable to detect SDK in the selected directory

SDKのフォルダ構造が違うらしい

hackerslab.aktsk.jp

qiita.com

blog.naichilab.com

 

■ NDK not found

unity hubで対象エディターの「インストール」からモジュールを加える

→ NDKをインストール

qiita.com